Error on the Entry() action

Mar 1, 2011 at 7:51 PM
Edited Mar 1, 2011 at 8:04 PM

Hi:

I'm getting an error on the Entry Action that prevents me from publishingthe workfow. It says "this action has required Parameters that are missing."

Here's what I'm trying to do. I have a field called Body that is a rich text field populated by a form to email. Here's what the line looks like:

"Look at the delimetered entries of Current Item:Body, return index number 4, with a delimeter character :, and output value to Variable: Output result #1." (I've also tried it with different variables and delimeters)

Not sure were I could put any other parameters :)

Love to get this going, appreciate any help!


Coordinator
Mar 2, 2011 at 1:26 AM

Hi steam23,

This is due to a discrepency in the .actions file between the rule definitions and the parameter definitions (the actions file is located in the 12 hive, under TEMPLATE\1033\Workflow).  The same problem existed for some of the other Actions.  I've updated the .actions file in the Source Code repository, and uploaded a new WSP that includes this change also. 

Retract your WSP and deploy the new one, and all should be resolved.

Reply back here to let us know how you go.

- Mark

Mar 2, 2011 at 12:53 PM

That did it!

Nice work on these actions by the way. These functions should have been built in. You've just saved me a truck load of work!

Thanks.

Coordinator
Mar 2, 2011 at 1:14 PM

Good stuff - agreed they should have been built in. There's probably some more actions that should be built in also (either to this project, or in to SharePoint itself!).

And credit where credit is due - this project was inspired by Paul Galvin's 3 year old codeplex project - http://spdwfextensions.codeplex.com/ - the main problem with that WSP I found was that it wasn't obvious what functions it provided (which is why I split each function out to an action of its own).

- Mark